The carrier reports that inbound and outbound call patterns and overall network behavior have returned to expected levels. They will continue monitoring to ensure sustained stability. We will keep observing from our side and provide further updates if conditions change.
Posted Mar 03, 2026 - 10:29 EST
Identified
The upstream carrier has identified the issue and is actively working to mitigate the impact. We are monitoring progress and will provide further updates as additional information becomes available.
Posted Mar 03, 2026 - 09:56 EST
Investigating
We are currently observing issues with inbound and outbound calling through one of our upstream providers. Our engineering team is actively investigating the situation.
We will provide additional updates as soon as more information becomes available.